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Introduction to .NET Technology



What is .NET ?

Microsoft.NET 1s a Framework

— Microsoft .NET is a Framework which provides a common
platform to Execute or, Run the applications developed in
various programming languages.

— Microsoft announced the .NET initiative in July 2000.

— The main intention was to bridge the gap in
interoperability between services of various

programming languages.



.NET Framework Objectives

* The .NET Framework is designed to fulfill the following
objectives:

— Provide object-oriented programming environment

— Provide environment for developing various types of
applications, such as Windows-based applications and Web-
based applications

—To ensure that code based on the .NET Framework can
integrate with any other code
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* The .NET Framework consists of:

—The Common Language Specification (CLS)

It contains guidelines, that language should follow so that they
can communicate with other .NET languages. It is also
responsible for Type matching.

— The Framework Base Class Libraries (BCL)
A consistent, object-oriented library of prepackaged
functionality and Applications.

— The Common Language Runtime (CLR)
A language-neutral development & execution environment
that provides common runtime for application execution .



Common Language Specification

CLS performs the following functions:

* Establishes a framework that helps enable cross-language
integration, type safety, and high performance code
execution

* Provides an object-oriented model that supports the
complete implementation of many programming languages

» Defines rules that languages must follow, which helps
ensure that objects written in different languages can
interact with each other



NET Framework Base Class Library

The Class Library is a comprehensive, object-oriented collection
of reusable types

These class library can be used to develop applications that
include:

— Traditional command-line applications

— Graphical user interface (GUI) applications

— Applications based on the latest innovations provided by ASP.NET
 Web Forms
* XML Web services

Unified Classes
Web Classes (ASP.NET)

Controls, Caching, Security, Session, Configuration etc

Data (ADO.NET) || Windows Forms
ADO, SQL,Types etc Design, Cmpnt Model etc




Common Language Runtime (CLR)

* CLR ensures:

— A common runtime environment for all .NET languages
— Uses Common Type System (strict-type & code-verification)
— Memory allocation and garbage collection

— Intermediate Language (IL) to native code compiler. Which
Compiles MSIL code into native executable code

— Security and interoperability of the code with other
languages

* Over 36 languages supported today

— CH, VB, Jscript, Visual C++ from Microsoft

— Perl, Python, Smalltalk, Cobol, Haskell, Mercury, Eiffel, Oberon, Oz, Pascal, APL,
CAML, Scheme, etc.
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Visual Studio 2008 IDE

Microsoft has introduced Visual Studio.NET,
which is a tool (also called Integrated Development
Environment) for developing .NET applications by
using programming languages such as VB, C#,
VC++ and VJ#. etc.



C# (C Sharp)

Microsoft C# (pronounced C Sharp) developed by Microsoft
Corporation, USA

New programming language that runs on the .NET Framework

C# is simple, modern, type safe, and object oriented

C# code is compiled as managed code

Combines the best features of Visual Basic, C++ and Java



C# Features

Simple

Modern
Object-Oriented
Type-safe
Versionable
Compatible

Secure



Introduction to Web Based
Applications



Introducing Web Applications

Web Page Static web page

« This type of web page consists of
HTML code typed directly into text

or a web page editor
 ltissaved asan .htmor .html
file

« The content (text, images, hyperlinks, and so on) and
appearance of a static web page iIs always the same.

 These web pages do not utilize any database or any
other technology that dynamically builds up pages or
content at runtime based on their visitors input.
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2.

1.

How Are Static Web Pages Served ?

WEB SERVER

Author I
writes
HTML

Client requests
the web page

3. Web Server locates
.html file

4, HTML stream( from the
.html page) returned to

the browser

5. Browser processes
HTML and displays

page

CLIENT
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Dynamic web page

Dynamic Web sites provide its visitors to modify the content of

the web page based on their input.

They utilize databases and other mechanisms that enable to

— identify their visitors

— present them with customized greeting messages
— restructure the content according to user input etc..

Examples:

Web |mages Yideo MNews Maps Gmail

more v

Online shopping stores,
search engines
email

chat, community portals etc.

GOUgle ASP.NET (Searh ) A s

New! View and manage your w

Web

The Official Microsoft ASP.NET 2.0 Site

Microsoft portal site for the ASP.NET development community. Download Visual Web
Developer, post to the forums, read ASP.net blogs and leam about ASP.net,

www, asp.net/ - 41k - C ges

ASP.NET - Wikipedia, the free encyclopedia

ASP.NET is a web application framework marketed by Microsoft that programmers can use to
build dynaric web sites, web applications and XML web senvices. ...

en.wikipedia. orgfwiki/ASP.NET - 80k - Cached - Similar s

ASP.NET Developer Center

Microsoft ASP.NET is a set of Web application development technologies that enables
programmers to build dynamic Web sites, web applications, ...

msdn.microsoft. com/asp.net/ - 29k - Cached - Similar pages

ASP.NET Tutorial
At W3Schools you will find complete ASP.NET references about built-in objects and
components, and their properties and methods: ..
WA nols. com/aspnet/default. asp - 27k -

ASP.NET QuickStart Tutorials

Includes a series of ASP.NET samples and supporting commentary designed to quickly
acquaint developers with the syntax, architecture, and power of the ASP,

samples. gotdotnet. com/quicl faspplus/ - 1k - Cached - Similar page

Results 1- 10 of about 76,400,000 for ASP.NET. (0.19

Sponsored Links

Need ASP.NET Web Ho
SQL 2005, 4GB Space & 2477
Get Started Today For Only §
ww HosthySite. com

ASP.NET. Spreadshest(
ASP.NET Excel Reporting ant
Windows Forms Spreadsheet
wwnw. SpreadsheetGear.com

Project Insight Web PM
Robust enough for sawy PMs
easy enough for team membe
www. projectinsight.net

New Adobe Tech Comm
Author, Manage & Publish En
Technical Documentation. Les
. Adobe. com

Free ASP.NET Training '

Try our award-winning training



Dynamic web page

* Dynamic Web sites make use of “server-side
technology”.

e Server-side technologies add an extra layer to the
static web page that enables the Web Server to

generate HTML on the fly.
* The web server will first
— interpret the server-side code present in web
pages,
— generate the appropriate HTML and then
— send the response to the web browser.



How Are Dynamic Web Pages Served?

3. Web Server collects the contents
n (code + HTML) of the web page
WEB SERVER and parses the contents to

produce HTML.

2. The Web Server
searches for the

requested page 4. The HTML stream is

sent back to the
requesting browser

5. Browser processes
HTML and displays

page

1. The Web browser
sends a request

CLIENT
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Introduction to ASP.NET

ASPnet



Introduction to ASP.NET

® ASP.NET is part of the Microsoft .NET framework

® ASP.NET is an effective and flexible technology for
creating interactive and dynamic web
pages.

® |t is a convergence of two major Microsoft technologies:

— Active Server Pages (ASP)

* Active Server Pages is Microsoft’s server side scripting
technology for building dynamic web pages.

— .NET Framework

 The .NET Framework is a suite of technologies designed by
Microsoft where program development takes place.
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Introduction to ASP.NET

® |t is built on .NET Common Language Runtime
® ASP.NET :

® Provides better user authentication
® Has better language support.
® Has a large set of new controls (web controls)
® Uses compiled code, which increases the performance of the
applications
® |t is programmable using any of the .NET languages
(VB.NET, C#, VJ# etc).

® The ASP.NET pages are saved with the . aspx
extension.



Working of an ASP.NET Application

To execute an ASP.NET file, the

2.

3.

following steps are followed:

A web browser sends a
request for an ASP.NET file to
the web server by using a
URL.

The web server receives the
request and retrieves the
appropriate ASP.NET file from
the disk or memory.

The web server forwards the
file to the ASP.NET script
engine for processing.

» ASP.NET

Script
Engine

CLIENT
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Working of an ASP.NET Application

4. The ASP.NET script engine reads

the file from top to bottom and
executes it.

5. The processed ASP.NET file is
generated as an HTML
document and the ASP.NET
script engine sends the HTML
page to the Web server.

6. The Web server then sends the
HTML code to the client which
interprets the output and
displays it.

» ASP.NET

Script
Engine

CLIENT
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Advantages of ASP.NET

Easy Programming Model
Flexible Language Options
Compiled Execution

Rich Output Caching
Web-Farm Session State
Enhanced Reliability
Master Pages

Themes

Improved Security

Web Services

Improved Performance and Scalability



Visual Studio 2008 IDE
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Creating a New Web Application

To start a new Web Application in VS 2008, Click the Create Web Site
button on the Start page or Select File > New > Web Site

New Web Site @@
. ( Templates: |
The NeW Web Slte a”OWS gsual‘j%nstalledtemplates
you to choose: N2 2 @ &
ASP.NET Web JASP.NET Web Personal Web  Empty Web ASP.NET
Site Service  Site Starter Kit Site Crystal Re...
‘ Te m p I ate S My Templates
- Language for creating an 5
application T
- Location where the application | iewes
will be created - Flesyen [ Ciesetigpcat (oo ]
[ OK l[ Cancel ]
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Creating a New Application
(Continued)

= After you create a new Web Application, Default.aspx page is added to this
Website. To Rename this page, Select the page from the Website node in the

Solution Explorer > Right Click > Rename,_ s — .

Add New Item - C:\Documents and Settings\hussain. patel\My Documents\Visual Studio 2005\Webs...
= Files can be added to the Project, e o)
. . Yisual Studio installed templates »
using Solution Explorer: ™ — B e
. . . . @] HTML Page ) Web Service <] Class
= Right click on the project node, in || e g sl s o
the Solution Explorer, and select i | S A
the Optlon Add NeW |tem %]T:c{:r;ﬁb o .;%‘]m:l';\:lebeuser Contral ?%Z?;::wébbmnngmamme
t X7 Die - .y Skin File D ]Browser Fi
= The Add New Item window will i

popup. :

EVA Fon;for Wel; Awic;t'ons
= Select the type of file (item) to be  u=  [ofxe
. Language: Visual C# v v|Place code in separate file
added and click on Add. s PR e

[ Add ] [ Cancel

X Remove

Property Pages
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Solution Explorer

= Presents a tree view structure of files

Solution Explorer - Solution "WebSite1' {1 project) v I .
present in the project. 2 E B e
. ) . /] Solution "WebsSite1' (1 project)
— By default a New Website will contain: S P C\..\Websitel\,

* An App_Data folder = [ Defauk.ag)

N
A Default.aspx page (including
Default.aspx.cs)

To view Solution Explorer:

= Select View > Solution Explorer
OR

= Press buttons Ctrl+W,S
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Solution Explorer (Continued)

= The Toolbar at the top of Solution Explorer enables various tasks.

Code
Refresh Copy Website

Solutior| Explorer - folution "websSited' (1 p.., » B X

= | (][5 [ T T3] i

View
Designer

Properties

Nest ASP.NET
Related Configuration
Files



Toolbox

To add controls in the Design Window use
Toolbox.

There are various tool tabs available in the
Toolbox.

— The controls in the IDE are presented in a
hierarchical manner (e.g., Standard Tab, Data Tab,
Validation, Navigation, WebParts etc.).

— Depending on the type of project (application) the
toolbox tabs will vary.
To view the tool box:
— Select menu View > Toolbox
OR
— Press buttons Cirl+Alt+X or Ctrl+W, X
You can also view the controls as icons by right-

clicking on the toolbox you want to change and
deselecting the List View.

| # Standard |

= Data

R Pointer

o Gridview

| Datalist

J._] DetailsYiew

_._] FormView

| Repeater

| ] sqiDatasource

L » AccessDataSource
;.3 ObjectDataSource
." *miDataSource
L;g.‘ SiteMapDataSource
=il ReportViewer

i+ ¥Yalidation

i+ Navigation

i+ Login

'+ WebParts

i+ HTML

i+/ Crystal Reports
=l General

There are no usable controls in this group. Drag
an item onto this text to add it to the toolbox.




Properties Window

To view or change the properties and events of a selected control during
design use the Properties Window

To configure a control:
— Click once to select it

— Press F4 or Select menu View > Properties
window

— Modify the appropriate properties in the window

There are various options provided for viewing
the properties of the selected control, such as:
— Categorized view
— Alphabetical view
— Properties view (default)
— Events View
— Property pages oeh e

{ID) Button1

Properties o Xx

webControls.B « I

True
True
o

True
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Addmg an Event

[ Solutlon Explorer C 'l.TestWebAppllcatlon\, -~ B X
Events can be added to = sﬂ SR=RloR |
:

the COde In One Of three Buttonl Systegmyweb.UIL.WebControls.Button =

ways:

. - m—
1. Double clicking a control in | Somperd ===

design view =

Load

2. Typing the code manually PreRender

Unload

3. Selecting the Events lcon
and double clicking the
required event from the
Properties Window

Click
Fires when the button is clicked.

359



Project Settings

Project Settings can be adjusted using
various options in the Project
Properties menu or by using the
Solution Explorer window.

— These settings change based on the
type of application developed.

Setting Startup Page:
— Right Click on the form you want set as

the startup page in the Solution Explorer.

— Select option Set As Start Page.

Startup Project (In case of multiple
projects):
— Right Click on Project to set as startup
project in the Solution Explorer.

— Select Option Set As StartUp Project.

=

L5#| Reservi
- [=d Prqg
= |&F Rel

| Solution Explorer - C:%Sonali', CustomerManagement’,
2 Fldy & 3@

(A Solution 'CustomerManagement’ (2 projects)
= 4 alit CustoamerManaaemenk’

s ,
Build Web Site

Publish Web Site

Add New Item...

Add Existing Item...
Mew Folder

Add ASP.MET Folder
Add Reference...

Add Web Reference...
View Class Diagram
Copy Web Site...
Start Options...

Set as StartUp Project

View in Browser
Browse With...
Refresh Folder

Add Solution to Source Contral...

Cut

Remove

Property Pages




Resources

* Visual Studio 2008 Website
http://msdn.microsoft.com/vstudio/
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http://msdn.microsoft.com/vstudio/

Questions and Comments
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